- Use your browser cookie tool to find the cookie of youtube.com
- Locate the Cookie with the name “PREF”
- Change the value to or append to the end of the existing value “f6=4008”
Prerequisite
- Have Homebrew installed on your Mac
Install Dependencies
- Install FUSE for macOS (https://osxfuse.github.io/)
- Install cmake
brew install cmake - Install PolarSSL
brew install PolarSSL - Download Dislocker and unzip (assuming that you unzipped it into ~/Downloads/dislocker-master/ folder)
- Install Dislocker
brew install ~/Downloads/dislocker-master/dislocker.rb
Load BitLocker Protected Drive
NTFS Filesystem
- diskutil list
- Use diskutil to find the identifier of your drive
- mkdir -p /mnt/externalhdd
- sudo dislocker-fuse -V /dev/<your_disk_identifier> -u<your_bitlocker_password> — /mnt/externalhdd/
- sudo hdiutil attach -imagekey diskimage-class=CRawDiskImage -nomount /mnt/externalhdd/dislocker-file
- The output of this line is the path to the virtual device – it would be something like /dev/disk3
- mkdir -p ~/Desktop/externalhdd
- mount -t ntfs -o rw,auto,nobrowse <path_to_virtual_device> ~/Desktop/externalhdd
Then your disk will be shown on your desktop
Non-NTFS Filesystem
- diskutil list
- Use diskutil to find the identifier of your drive
- mkdir -p /mnt/externalhdd
- sudo dislocker-fuse -V /dev/<your_disk_identifier> -u<your_bitlocker_password> — /mnt/externalhdd/
- sudo hdiutil attach -imagekey diskimage-class=CRawDiskImage -nomount /mnt/externalhdd/dislocker-file
Then you will be able to see your device in your finder’s “Devices” section
Unload Drive
- Eject your drive by either right click-eject or eject from your finder’s “Devices” section
- Or eject with command line
sudo hdiutil eject ~/Desktop/externalhdd
- Or eject with command line
- hdiutil detach /mnt/externalhdd
- Then it’s safe to remove your external drive
Credit to raphaunix
echo "LC_ALL=en_US.UTF-8" >> /etc/environment
echo "en_US.UTF-8 UTF-8" >> /etc/locale.gen
echo "LANG=en_US.UTF-8" > /etc/locale.conf
locale-gen en_US.UTF-8
方法1
- stop running container
docker stop test01
- commit the container
docker commit test01 test02
NOTE: The above,
test02
is a new image that I’m constructing from thetest01
container. - re-run from the commited image
docker run -p 8080:8080 -td test02
方法2
- stop running container
- find docker container in the file system
- In Linux, it’s most likely here
/var/lib/docker/containers/
- In Mac, follow this document
- In Linux, it’s most likely here
- Update “PortBindings” in hostconfig.json, and “ExposedPorts”, “Ports” in config.v2.json or config.json
- Restart docker daemon
/etc/init.d/docker restart
- start your container
C:\Users\[你的用户名]\AppData\Roaming\Microsoft\Windows\Themes\CachedFiles
近期评论